Picture: ubuntu-mate.org

Fix Firefox crash on Ubuntu Mate

Unfortunately, currently the latest versions if Firefox (current: 61) on Ubuntu Mate are not supported. Firefox crashes. The latest version that runs on Ubuntu mate is the 42.

To see all the versions that are currently known, madison helps. madison is a small developer tool to read the apt-cache.

This is part of devscripts, which must be installed first.

sudo apt-get install devscripts

Now madison can be used.

sudo apt-cache madison firefox

The result is:

[email protected]:~$ sudo apt-cache madison firefox
[sudo] password for ben:
   firefox | 61.0+build3-0ubuntu0.16.04.2 | http://ports.ubuntu.com xenial-updates/main armhf Packages
   firefox | 61.0+build3-0ubuntu0.16.04.2 | http://ports.ubuntu.com xenial-security/main armhf Packages
   firefox | 45.0.2+build1-0ubuntu1       | http://ports.ubuntu.com xenial/main armhf Packages
   firefox | 45.0.2+build1-0ubuntu1       | http://ports.ubuntu.com xenial/main Sources
   firefox | 61.0+build3-0ubuntu0.16.04.2 | http://ports.ubuntu.com xenial-updates/main Sources
   firefox | 61.0+build3-0ubuntu0.16.04.2 | http://ports.ubuntu.com xenial-security/main Sources

All versions are displayed, including the version 61 not running on Ubuntu mate. But also the version that we need: version 42.

With the command

sudo apt-get autoremove firefox

you can now uninstall the current version on the system. Now you can install version 42.

sudo apt-get install firefox=45.0.2+build1-0ubuntu1

After the installation and the first start, Firefox will report that a new version is available. Do not install, otherwise you can start over again. :-)